読者です 読者をやめる 読者になる 読者になる

ベスパライフ

日記・備忘録。ベスパもってないです。

似たような機能の関数を区別しやすいような関数名をつける

命名規則

「左側のメニューにある複数のボタンのそれぞれについて、クリック可能/不可能を更新する」みたいな関数名をつけるとき、次の2種類を考えた。
・UpdateLeftSideMenuClickable
・UpdateClickableOfLeftSideMenu

どちらがよいか悩んだ時の方針として、とりあえず似たような機能の関数をつくってみる。

・UpdateLeftSideMenuClickable
・UpdateRightSideMenuClickable
・UpdateTopMenuClickable
・UpdateBottomMenuClickable

・UpdateClickableOfLeftSideMenu
・UpdateClickableOfRightSideMenu
・UpdateClickableOfTopMenu
・UpdateClickableOfBottomMenu

下側のほうが「UpdateClickableOf」まで共通なので、ぱっと見て区別がつくし、整理されている。
下のほうが良いよね、という話。